Problème Archlinux et UEFI
08-19-2013, 15:26:08, (Ce message a été modifié le : 08-19-2013, 15:27:52 {2} par Sushi.)
#1
Problème Archlinux et UEFI
Salut,

Alors voila je viens de changer de pc et ce dernier est équipé d'un vrai UEFI (mon ancien avait un UEFI mais il pouvait démarrer en legacy).
J'ai donc des soucis pour installer Archlinux.

Que ce soit avec grub-install ou efibootmgr, lorsque je suis en chroot sur le live-cd, à chaque fois j'ai un message d'erreur comme quoi le programme ne peut pas modifier les variables efi.
Mais j'ai pu contourner ce problème en créant directement une entrée de boot à partir du shell UEFI.

Mais ensuite grub-mkconfig ne trouve aucun os ni même le kernel linux de Arch, il me dit qu'il a un soucis avec lvm ce qui n'est pas logique vu que mon SSD a une table de partitionnement GPT et donc que toutes les partitions sont primaires. Du coup mon grub est vide et ne sert à rien...

Voila si quelqu'un ayant installé Arch sur UEFI/GPT passe ici et qu'il a une idée, qu'il n'hésite pas Wink .
Merci d'avance.
08-19-2013, 18:30:38, (Ce message a été modifié le : 08-19-2013, 18:37:05 {2} par Bruce.)
#2
RE: Problème Archlinux et UEFI
Normalement l'uefi se désactive (sinon tu as un constructeur connard Big Grin), donc si tu as la flemme de rester sur du partitionnement GPT tu peux repartir sur du MBR.

Sinon have fun !
08-19-2013, 21:04:00,
#3
RE: Problème Archlinux et UEFI
Impossible mon Windows étant préinstallé en UEFI/GPT et vu que c'est une license OEM pas de réinstallation possible...
En plus chez Asus, pour désactiver l'uefi c'est bien planquer faut passer "Launch CSM" sur Enabled pour avoir les options de boot Legacy pour SATA apparaître...

Mais sinon j'ai résolu mon problème (en uefi Tongue) en gros sous Linux pour modifier les variables efi faut lancer un module appelé efivars mais je le lançait tout le temps dans le chroot alors qu'il fallait le lancer dans le live avant de chrooter (c'est marqué nulle part dans le wiki super! Big Grin)

Malgré 2 jours de galère je suis satisfait, parce qu'avec efi même plus besoin de bootloader et GPT c'est 128 partitions primaires max donc plus d'emmerde avec LVM.
08-19-2013, 21:10:05,
#4
RE: Problème Archlinux et UEFI
(08-19-2013, 21:04:00)Sushi a écrit : En plus chez Asus, pour désactiver l'uefi c'est bien planquer faut passer "Launch CSM" sur Enabled pour avoir les options de boot Legacy pour SATA apparaître...
Ils ont du changer leurs bios alors, j'ai un ASUS et l'option est plutôt claire dans le bios, enfin c'est réglé, c'est déjà ça Big Grin
08-20-2013, 01:05:42, (Ce message a été modifié le : 08-20-2013, 01:10:02 {2} par Sushi.)
#5
RE: Problème Archlinux et UEFI
Oui sur ma tour j'avais aussi un UEFI asus et il était beaucoup plus clair.

Bon maintenant j'ai un soucis de surchauffe phénoménal Undecided

Je suis à 80° en IDLE avec le proco qui tourne à 800 Mhz.
Et j'arrive pas à faire marcher Bumblebee (Optimus pour Linux) pour éteindre la carte Nvidia...
J'ai limite l'impression que les ventilos sont éteint.


Aller à :


Utilisateur(s) parcourant cette discussion : 1 visiteur(s)